Skip to main content


 

Domain blocking


!iSurf Support

I have another tech support question. I wonder when they're going to add the ability to block domains. I've stumbled across whole servers that are devoted to unsavory and illegal content, apparently out of Asia, but see no way to block it.

I considered superblocking with wildcards but have read that this doesn't work, so I haven't tried it.



 

Minor bug in web interface...I think


!iSurf Support

I think I've found a little bug in the Friendica web interface. I'm not sure where to report it.

Running Firefox on Linux here. It appears that the thumbs up/down indicators are not updating properly. Here's what happens.

If I click thumbs up, the display goes gray for a moment, then the thumbs up turns blue, as it should. If I click the thumbs up again, which should toggle it off, the display grays for a moment but the icon remains blue. You can click again and again and it remains blue. You can click thumbs down and the same thing happens. You can have both thumbs up and down showing blue.

A bit of experimentation manually refreshing the display shows that the click detection and server behavior is correct. The second click actually does toggle it off at the server. It's just the browser display code that's not updating the color.

I'm back. I flushed the cache and cookies. Now I have a slightly different behavior. I still can't unthumb a thumbs up but I can now hit thumbs down and it clears the thumbs up and switches to thumbs down, and vice-versa.

@Phil Landmeier (ᚠ) Hey Phil... got any add-ons enabled in FF?

If it's consistently weird, probably best to post findings on @Friendica Support

I'll have a look myself, but don't have much time this week to dig in to working up good support posts, unfortunately.

Basically, no. The only extension I'm running is Stylus and it only activates when the domain is mewe.com

Also, the problem is deeper than just the browser. The bug involves the server too.

There are two discussion threads about this. In the other thread, one of the commenters also got his browser to display both thumbs up and down at the same time, which should be impossible. The thing is that once he did that, I had the same indication on my browser. It showed him as both liking and disliking the comment. For that to happen, the server must be in an invalid state.

Hey @Phil Landmeier (ᚠ) - what's the other thread you're referring to?

I first posted in my stream. Then Shelenn suggest I post here in the community, so two threads resulted. The other is here:

https://social.isurf.ca/display/c443a55c-215c-bfb2-529a-430799099599